Can any body tell me how to provide different URL's to the each different extended web applications in different zones (intranet,extranet,default,internet) on SharePoint 2013. Since I am extending one of the SharePoint 2013 webapplication.

Is it necessary to create or provide host header to the web application if we have to extend it.

Or without providing host header to the web application can we extend the SP2013 web application by providing it the different URL?

1 Answer 1


when you extend a web application, at that you can enter the url. or leave it with server & port numbers.

  1. Once the Web app extend, you can go the Central admin > Application managment > Configure the Alternate Access Mapping.
  2. Now on this page, select the web application
  3. click on edit the Public URL.
  4. Over here you can enter the DNS / URL what ever you want in the required zone.


  • I entered the url, "portal.mycompany.com" as told by you in the default zone but after hitting the url it is giving the error "This page can't be displayed" make sure your web address is correct or not. Port numbaer of my site is 5048 & public URL for default zone is "sp13dev:5048" Jun 11, 2015 at 14:19
  • did you created the DNS record which points to Sharepoint server or it just host file entry? in which zone you extend the web application? also try to access it portal.mycompany.com:5048
    – Waqas Sarwar MVP
    Jun 11, 2015 at 14:21
  • No I did'nt created any DNS record that points to the server. And I am extending the web application to intranet zone. What is host file entry? Jun 11, 2015 at 14:23
  • if you extend the web app into intranet then why you changing the default zone url...you should change intranet....can you share your AAM setting screen shot.
    – Waqas Sarwar MVP
    Jun 11, 2015 at 14:31
  • My intranet url is "sp13dev:19378" both as internal url & public url for that zone, and after hitting that it is giving me the same error so what should I do so that it will open my web application root level site. Jun 11, 2015 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.