0

Previously I've been able to edit workflows without any problem on our Sharepoint 2010, using Sharepoint Designer.

when i try to publish it , have encounter message, that i have not enough right to do this opertation, and when i click cancle the show me this one , that

"Could not publish the workflow because the workflow configuration file contains errors."

Even though when I "Check for Errors" it says there are no errors.

I've googled it and I've tried some of the suggestions, such as setting an "executionTimeout" attribute on httpruntime in the web.config and restarting IIS, but that hasn't helped.

Another suggestion said to Deactive the Workflow feature on the whole sharepoint and Activate again, but the warning that comes up before I do it says data may be lost, so I am concerned that if I deactivate it it's going to delete all the many workflows we have across our subsites, as I wouldn't put it past Microsoft to have something like that happen, considering all the numerous other problems Sharepoint and Internet Explorer cause us.

I tryed all possible tricks to solve it but didn't work any one (( Has anyone got any ideas as to what might be causing this, or how to fix it? Are there any error log files I can look at to find more detailed error information?

Thanks.

0

Solution:

what i explore by my self , after few days by searching and experiment ...

This solution is to resolve this issue, install the hotfixes that are provided in the following articles in the Microsoft Knowledge Base:

2687614 (http://support.microsoft.com/kb/2687614/ )

Description of the SharePoint Server 2010 hotfix package (Coreservermui-xx-xx.msp): October 30, 2012

2687557 (http://support.microsoft.com/kb/2687557/ )

Description of the SharePoint Foundation 2010 hotfix package (Wss-x-none.msp): October 30, 2012

I installed those in the Pre-Production Server and Update my Farm. Each time I run “SharePoint 2010 Products Configuration Wizard” to Update Farm (It is required to Update Farm who doesn’t know about it)

Error still not solved !!!

Finally I did the following:

Open SharePoint management shell as administrator and run the bellow command

$app = get-spwebapplication http://portal

$app.UserDefinedWorkflowMaximumComplexity = 10000

$app.Update()

Then I try to publish the workflow and it works without any problem.

I found Details at http://support.microsoft.com/kb/2557533

Maybe it will be useful to someone else !!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.