0

I have a workflow history list that is large so I have gone into information Management policies and set a LIST based retention schedule with a stage that deletes items that are 1 day greater than the 'Created' Date: (Created + 1 days Permanently Delete (Recurrence = No). Something is obviously not working because the workflow history list is growing and nothing has been deleted. I Googled the issue and found the following StackExchange link which educated me a little on the back end mechanics. I checked the jobs for expiration policy and Information management policy were working i.e. no errors and also ran them both and then set them both to daily but the list is still growing. Any ideas? Pictures: enter image description here enter image description here enter image description here

  • That should take care of it, we made those alterations in our farm to run daily and have not seen any problems. Make sure the information management policy runs before the expiration job and that you configured them for the right web application (there are jobs for each web app). – Eric Alexander Jun 10 '15 at 13:49
  • I just manually ran the IMPolicy and then the ExpPolicy in that order and the list has still had no deletions occur on it. Is there something I/m doing wrong in regards to configuring the list information policy at the list level. For instance I'm not sure what it means by records and non-records!? – JazzyN Jun 10 '15 at 14:46
  • Can you include a picture of the configuration? – Eric Alexander Jun 10 '15 at 15:11
1

Those configurations look to be correct so long as the IMPolicy timer job runs before the ExpPolicy timer job. This then leads me to believe it is something with the policy you are not configuring correctly.

Here is an example config on a library I have to delete documents that are over 45 days old. This has been working flawlessly without issue since creation. In your scenario, you could change it to Permenantly Delete.

enter image description here

EDIT: I believe thi s is because you have set the retention policy on records so when the timer jobs run nothing happens, unless you mark those entries as records. You want to use the upper block, the non-records section configured like you have it and you should see the items get deleted.

  • How do I upload photo's?? – JazzyN Jun 11 '15 at 7:57
  • I have noticed under the Job History that when the IMP runs it appears to take 20 seconds and succeeds but then there are another 8 entries that take 00:00 duration and still labelled as succeeding!? – JazzyN Jun 11 '15 at 10:30
  • 1
    There is a little picture icon in the toolbar of the text editor that will allow you to upload pictures. – Eric Alexander Jun 11 '15 at 11:55
  • Pictures added...didn't realise I had to 'EDIT' original post. Thanks – JazzyN Jun 11 '15 at 12:41
  • 1
    Updated answer, it is because you have it configured on Records, not the non-records section. – Eric Alexander Jun 11 '15 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.