4

I am getting the below error

Failed to create term set: A default managed metadata service connection hasn't been specified.

I was trying to create a site collection specific termset for the purpose of navigation.So I went to my site settings and Navigation and clicked on the CreateTermset button.After this, I am getting the mentioned error.

What am I doing wrong? I have 2 MMSs created in my production environment.I can not check the checkbox for This service application is the default storage location for column specific termsets in my central admin because another MMS's settings is set to checked for this feature. So how to resolve this issue for my newly created MMS.

3

You need to associate your metadata application with the default application proxy group. Go to Central Admin > Application Management > Configure Service application associations.

In the top right corner on the page, change the view to Service Applications. Click the "default" proxy group and check the box for your second Metadata application. Click OK and try again.

Or if you are using multiple application proxy groups for your different web applications, you need to make sure that the managed metadata is in the group that you are using for the specific web application that you are working on.

  • I already have another MMS created by my customer, when they provisioned the SP 2013 Farm and my customer IT team already checked the checkbox for that. And default proxy group can not be set for my newly created MMS. So thats why I am not able to set the settings for new MMS. – SaMolPP Jun 10 '15 at 12:37
  • 1
    So can't you use the other managed metadata service for your navigation? The problem is that you have 2 metadata services associated to your web application and you can only have one default. Do both manage metadata services need to be used by the same web application? If yes, then you need to change the default manage metadata application as described in the blogs you posted, or store your custom navigation in the one that is default. – Christoffer Jun 10 '15 at 12:52
  • 1
    Then head over to Central Admin > Application Management > Configure Service application associations. from the View, choose Web Applications and click on your web applications name. Do it uses the default proxy group or a custom group? If default, set it to custom, select the necessary service applications, including the managed metadata service you wanna use and set it to default and see how it works out for you. – Christoffer Jun 10 '15 at 13:23
  • 2
    When you are sure that your managed metadata service is the only on associated to the web application, you can go to service application and set it to be default for the web application. You will still be warned but if you read the message it clearly says that its applicable only if the service is associated to multiple web applications. "Warning: Another service application on this farm is already configured as the default. This feature will be disabled if multiple defaults are associated with a single web application. " – Christoffer Jun 10 '15 at 13:28
2

Follow below steps and try, if accepted answer does not work.

  1. In the central administration --> Manage Service Application Page, click on the line corresponding to the connection (not on its name, on its right) and click on "Properties".

    enter image description here

  2. Click on the "This service application is the default storage location for column specific term sets" checkbox and click on "OK"

    enter image description here

  3. Or you can use the following PowerShell commands:

    $MMAProxy = Get-SPServiceApplicationProxy | Where-Object { $_.typename -like "Managed*" }
    $MMAProxy.Properties.IsDefaultSiteCollectionTaxonomy = $true
    $MMAProxy.Update()
    
  4. You can now create Term Sets enter image description here

I have got the answer from SharePoint 2013: Failed to create term set: A default managed metadata service connection hasn’t been specified

  • Thanks. This can happen if you create second Managed Metadata Service Application (MMS) or connect from different farm and then remove it. The first MMS does not become default automatically. – Lukas Nespor Apr 1 '18 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.