0

I have a custom list in a SharePoint 2013 site with just one column. Then I implemented a workflow using SharePoint Designer 2013. The workflow only send an email to myself with the title of the new item. I have three groups in the website:

  • Members- Contribute
  • Owners - Full Control
  • Visitors - Read

When a user belonging to the Owners group creates a new item in that list the workflow finishes and the email is sent perfectly. When a user belonging to the Members group creates a new item, the workflow gets cancelled and the email is never sent.

I tried modifying the list permissions, giving access to Members group to Workflow Task List and Workflow History but nothing seems to work. I got this error:

RequestorId: 170d2919-dd32-0503-0057-1a030da463d7. Details: System.ApplicationException: HTTP 401 {"Transfer-Encoding":["chunked"],"X-SharePointHealthScore":["0"],"SPClientServiceRequestDuration":["7"],"SPRequestGuid":["a6c775de-ca84-441a-b978-ee53e06ed509"],"request-id":["a6c775de-ca84-441a-b978-ee53e06ed509"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"MicrosoftSharePointTeamServices":["15.0.0.4569"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Cache-Control":["max-age=0, private"],"Date":["Tue, 09 Jun 2015 01:56:36 GMT"],"Server":["Microsoft-IIS/8.5"],"WWW-Authenticate":["NTLM"],"X-AspNet-Version":["4.0.30319"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem

Am I missing something???

0

User with the default contribute level permission can also start workflow automatically, but when “Edit Items” permission is not checked, user will get the error.

Can you please create a new group with contribute permission and see if it is working for it or not

  • Thank you your answer but still not working, unless the user has Full Control permissions, (it doesn't matter if it is just a user or it is inside a group) the workflow gets cancelled when the action Send email is included in the workflow – Yennifer Yero Jun 9 '15 at 11:48
0

I have to create a workflow with elevated permissions by using the SharePoint 2013 Workflow platform. By default, workflow does not have permissions to access the app request catalog. Catalog lists in SharePoint require owner (full control) permissions. Workflows generally run at permission level equivalent to write.

To solve this, you have to create a workflow with elevated permissions by doing the following in the App Catalog site:

1.Allow workflow to use app permissions. 2.Grant full control permission to workflow. 3.Develop the workflow to wrap actions inside an App Step.

J just have to follow the first step: I located the feature called Workflows can use app permissions, in manage site features, and then click Activate.

Then in my workflow, I insert Send Email action into an app step that is now enabled because off the activated feature. I hope this help. For more references: https://msdn.microsoft.com/en-us/library/office/jj822159.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.