I would like to give anonymous access to pages. So, for that I have given anonymous view items permission to pages list. So, all pages are anonymously accessible.

I have group name "GrpTest". The group has Contributor permission. Now I want to assign that group to pages item level. For that I have to first stop break inheritance permission and then I have to assign group permission. But as soon I break the permission anonymous permission is removed.

How to give permission to specific group as well as anonymous user also?

  • Have you tried my given solution? Did it work for you?
    – Hardik
    Commented Jun 13, 2016 at 9:25
  • If you got the solution than kindly post here. Did my answer helps you?
    – Hardik
    Commented Jun 21, 2016 at 8:58

2 Answers 2


By default SharePoint does not support the item level permission to anonymous users. You can refer the work around posted in this article. But my personal opinion would be not to go for that. As it requires to create the AD user and create module etc. If there is one page only to which you are required to give the permission to anonymous users, you can move that item to new library and manage permissions there.



You can enable Anonymous Access by going to Application Management in Central Administration, Highlight the WebApp where you want to enable Anonymous Authentication, Click on Authentication Providers, Click on the Zone where you want to enable Anonymous Access, then Check Enable Anonymous Access, Save.

Go to your Web Application and the top level of the site collection > Site Actions > Site Settings > Site Permissions > Anonymous Access > List and Library

After that you can set each of your page to give anonymous user permission to read your page

Below Given link has a the above walk through with screen shots

SP2010 Branding Tip #9 – Turn on Anonymous Access

  • Is above given solution works for you?
    – Hardik
    Commented Jun 15, 2016 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.