4

IMPORTANT EDIT: It's happening in all sites and subsites! Not just in the newly created ones! Suddenly the workflows are not creating tasks anymore!

I've created a Sharepoint Approval Workflow on a list which fires every time an item is added. Yesterday everything was working fine, but today it's not adding tasks to Workflow Tasks lists, nor assigning tasks to the users I specify in Sharepoint Designer.

I've created several workflows, I tried creating a new Task List, I tried creating a similar workflow on another subsite, I tried using Sharepoint instead of Sharepoint Designer, nothing worked, it's not creating new tasks and it's not assigning users.

Please help... I'm stuck...

I deleted all the items from the associated List, that's the point where it stopped working.

I'm using Sharepoint 2013 with 2010 Approval Workflow.

I have an action when the workflow starts, to send an email to the initiator, and that works well, it sends the e-mail, but then it stops.

I just created a new subsite, a new list, a new simple approval workflow, and the problem is still there. Not creating tasks.

This is my workflow history (it's weird that it says duration:0):

enter image description here

  • Can you show us your SharePoint log, please? – Jio Jul 29 '15 at 8:33
  • What's the status of the workflow you see when it starts but fails to create the task? – Evariste Jul 29 '15 at 8:45
  • @Evariste it says 7/29/2015 11:47 AM Workflow Initiated -> no error or anything. It says In Progress – bloomingsmilez Jul 29 '15 at 8:54
  • How can I retrieve the Sharepoint log? The workflow says: 7/29/2015 11:47 AM Workflow Initiated (and In Progress) – bloomingsmilez Jul 29 '15 at 8:55
  • I deleted all the items from the associated List, that's the point where it stopped working. – bloomingsmilez Jul 29 '15 at 9:06
6
+100

Try replicating the same workflow with another new list. I am sure the schema of the associated list would have been corrupted. for further troubleshooting purposes, insert an email sending task or some item updating task in b/w or as a first step with some dummy content so you can know whether it is firing the workflow events or not.

  • Can you tell me how can I replicate the workflow to another list, please? – bloomingsmilez Jul 29 '15 at 9:41
  • Save as template and associate to list are grayed out in SPDesigner – bloomingsmilez Jul 29 '15 at 9:43
  • I managed to do it but it still doesn't add tasks – bloomingsmilez Jul 29 '15 at 10:10
  • is it a migrated site from older versions ? can you try creating a sample one in new web app with in the same server environment. are there any missing patches on the server farm ? is SQL server good in terms of space ? – kesava Aug 5 '15 at 1:44
2

Can you please make sure about the following steps:

  1. User have sufficient rights on the task list, I suggest using impersonation step
  2. As it happened all of a sudden, can you verify if 2010 workflow features are activated, it's possible that site admin have deactivated them by mistake.
  3. If none of this works can you create a new site in a different site collection or even in a different web app? This will narrow down our problem area. If workflows are not working in different webapps as well it can be a server related issue.

Please keep me posted.

1
  1. Can you try adding "Log to the history" action after each statement form your workflow, so that we will know from where it is breaking.
  2. are you seeing same behavior with all the users ID and your ID? Can you go and check permissions on TASK list.(In case someone changed permissions day before)
  3. Can you monitor number of items from Workflow task list, in case filter is placed for List view

Also refer this link, in case its similar issue.

  • I just created a new subsite, a new list, a new simple approval workflow, and the problem is still there. Not creating tasks. – bloomingsmilez Jul 29 '15 at 11:34
  • It's happening all around my Sharepoint. The workflows do not create tasks anymore. – bloomingsmilez Jul 29 '15 at 12:07
  • did you ever get that working? I have the same problem right now. I have been trying to fix it all day. – markasey Aug 26 '16 at 23:44
0

I had the same issue. When I checked my Tasks list my reusable workflow was using, it was empty so no Tasks were getting created. To fix it I went in to the workflow settings then hit OK to resave the changes. I guess there was corruption within the workflow or Tasks list.

0

Make sure you have "support scripts" as active in site features. Then turn the workflow site feature off then reactivate it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.