0

I have add a Web Part to my sharepoint 2013 site but I click on it in the Web Part Gallery, the site page return the following error

"$Resources:core,ImportErrorMessage;".

Can someone explain that and give me a solution?

  • is it custom webpart? did you copied from other site /webapp? – Waqas Sarwar MVP Jun 2 '15 at 14:17
  • It's Web Part which I have achieved on visual studio 2013 and I have uploaded the file (Web Part file) in The Web Part Gallery. – out-shire Jun 2 '15 at 14:34
  • so you did not deploy as a solution? – Waqas Sarwar MVP Jun 2 '15 at 14:44
  • I have deploy the solution but I didn't see the utility to do that because visual studio return the deploy was a succeed but nothing happen on the sharepoint site. – out-shire Jun 2 '15 at 14:55
  • You can use powershell to deploy the solution in sharepoint...use add-spsolution to add it farm then install-spsolution to deploy it. – Waqas Sarwar MVP Jun 2 '15 at 14:56
1

Looks like you have the custom webpart which you uploaded into the Site collections's web part gallery. I think you need to deploy and install that solution in order to use it.

Also check this post: Has anyone seen this error; $Resources:core,ImportErrorMessage;

  • I test your solution but my Power Shell console don't recognize the cmdlets. Maybe, you have do something for these cmdlets work and I haven't done it. – out-shire Jun 3 '15 at 9:03
0

When I created my SharePoint Project I did not select farm solution so i got the same Error Message when I tried to Add my WebPart to the Site.

to change it to farm solution change the project propertys:

Sandboxed Solution from true to false

Include Assembly In Package from false to true

Maybe this can help.

Did you add your Webpart an then got the Error Message or while you try to add it to the site?

  • Please don't add the exact same answer to this question, as you did on this one. Instead, try to specify your answer further to make it a better of this specific question. Thank You! – Benny Skogberg Mar 14 '17 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.