0

We have 2 WFE's and a Citrix NetScaler load balancer (LB). We have issues where the load balancer 'randomly' requests user to authenticate. We know this because the load balancer URL is shown in the authentication box. We have ensured that our web applications are trusted and that the logged on user's credentials are always used for web application access, however are not sure why the LB would be asking users to authenticate. Often if the user just closes down the box they can continue working but usually content linked to mysites is missing (user profiles images for instance - a red cross where the image should be)We are sure it happens for other cases but we cannot clearly qualify all other cases. If users enter their credentials and click to save username and password, we get mixed results and they often cannot get back to the intranet SP2013 site unless they clear out their Windows credentials.

Does anyone in the SP2013 world have experience with this issue?

0

What i am guessing it is because of two different web apps, one for mysite and one for other works.

  • I would use fiddler and trace it which page or content require authentication?

From you description, looks like it is mysite content which require the authentication, did you added the mysite URL into trusted zone?

Also check if the SSL causing any problem.

  • Thanks Waqas for your prompt suggestion. We did actually try Fiddler but when we put it on, the authentication boxes popped up for every mouse clicK! It was the same authentication box which contains the load balancer URL. This then suggested that our proxy server may have been part of the issue because Fiddler itself acts as a kind of proxy - we could not confirm or deny this aspect because we must go through our proxy server for normal external internet traffic but tell it to ignore local addresses (like our intranet site). This then removes the need for us to authenticate aganst the main in – user42967 Jun 4 '15 at 0:17
0

I have faced this issue, it might be case of security settings for Browser. this solved my issue

1.open IE > Internet options > Security. You will see different zones listed

  1. Select it and click Custom Level below that will open Security settings for that particular zone

3.Scroll down until you see User Authentication listed select Automatically logon with current Username and Password.

Repeat this for all zone where you want to apply this setting and try accessing

0

Which authentication model are you using ?

Assuming NTLM authentication, your browser has to be configured to support "Windows Integrated Logon".

In IE, go to the Tools Menu -> Internet Options -> Security Tab, click on Local Intranet, then click the Sites button, and then click the Advanced button.

In your IE browser you should a host name or wildcard host entry that matches your site.

This is what allows IE to pass the user's logon token to a remote server that requests authentication.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.