3

I am trying to add a provider hosted app in office 365 I have deleted the app from site content. I have deleted the app from the AppCatalog. Again I have uploaded same app in AppCatalog. Then I am trying to add the app to my site content (ie. click on Trust it). then It is displaying "sorry something went wrong with adding the app", and not adding app to site content.

Can any one please check this?

2

Try uninstalling the app and deploy it again.

In SharePoint 2013, you can get the app instance and delete it using Get-SPAppInstance Powershell command

In office 365, use Uninstall-SPOAppInstance to uninstall the app.


Sometimes adding an app in SharePoint 2013 does not work. It throws an error "Sorry,something went wrong". This can happen due to a lot of reasons. But sometimes this problem might be because of using a custom master page.

1

I'm not sure when this became available, but it is possible to find out the error that is preventing your app from installing:

  1. Go to your site's Site Contents.
  2. Open the app's monitoring page
    • In Modern UX, hover over the app, click the vertical ..., and click Monitor
    • In Classic UX, hover over the app, click ..., and click Details
  3. You should see a section called Errors
  4. Click the number for Install Errors or Upgrade Errors to see details about the error that occurred.
0

delete the app and its instances from the recycle bin also and then try. also check for the logs if possible for the exact failure

  • 2
    I deleted the app and its instance from the recycle bin but I also have the same problem,I can't check for the logs on share Point online. – N.Sahraoui Jun 1 '15 at 11:34
-1

"Napa" Office 365 Developer tools have been fully retired on March 31, 2017.

https://www.napacloudapp.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.