3

I've got a SharePoint 2013 Development server that is having issues installing applications developed within Visual Studio 2013. When attempting to install, the job just continues to run and never completes. Upon investigation, I noticed that the App Installation Service Timer Job is completely missing from the Job Definitions section in CA. Does anyone know of a way to get this Timer Job back?

I've tried PSCONFIG (which completed without error), removing and readding the App Management and Subscription Settings services, and running a repair install (which failed, more than likely due to the patch level of SharePoint on the server, Feb 2015 CU).

I'd really like to avoid the nuclear option of rebuilding this server, but at this point I'm ready to go that route...

Originally asked this question on ServerFault, but then thought to ask it here as well. Hopefully it doesn't get marked as a duplicate!

  • 1
    check this one if it solve the problem omicron-llama.co.uk/2015/03/27/… – Waqas Sarwar MVP May 30 '15 at 3:23
  • While that wasn't the 'exact' answer, you definitely pointed me in the correct direction! See answer below for full explanation, and thanks so much for helping out! – Nick DeMayo Jun 1 '15 at 11:12
2

Did this ever work correctly or is it something that has never worked?

I'll assume the later, which means there may be a mis-configuration or something missing from your farm.

  • Ensure you have a App Management and Subscription Service deployed
  • Ensure those services are started on the appropriate servers.
  • Ensure both applications are added to the default proxy group for the web application.
  • Check IIS and ensure the app pool running the service is running.

I'm not sure what provisions that job - but my guess is it's the App Management service. If the above doesn't work, remove your existing service application and create a new.

Edit I missed the part about the failed repair. Check that all your service application upgraded properly. You may want to attempt to re-apply the Feb CU and re-run PSCONFIG once more.

You can try to use Powershell commands below (PSCONFIG should handle these as part of the process as well).

Install-SPservice
Install-SPFeature -AllExistingFeatuers

I would go ahead and clear your configuration Cache as well and restart the servers. This step sometimes clears up mis-behavior jobs, though I have not encountered a situation where a job was missing all together.

  • This did used to work, and then stopped. I was on medical leave when it happened, and when I returned all the developer had to say was "the server crashed, and then I could no longer deploy apps!" The App Management and Subscription Services are deployed, running, and in the Default Proxy Group. Everything is running appropriately in IIS. It doesn't appear as though provisioning those services creates the timer job, as I've tried deleting them and recreating them, to no avail. – Nick DeMayo May 29 '15 at 16:29
  • Tried the powershell commands, and clearing the config cache, no go. Also no go on reinstalling the patch and re-running the PSCONFIG. I found this article (stevemannspath.blogspot.com/2013/02/…) for doing repair installs on the individual components, but that didn't work either. – Nick DeMayo May 29 '15 at 18:12
  • Well - in theory, if you can find the feature that deploys these jobs you could disable and re-enable them and that would most likely solve your issues. However - I'm not sure how you would actually go about tracking that down. I can't try it - but maybe just a shot in the dark - deploy a DEV Site template and see if that possibly activates the feature? I apologize but I'm running out of Ideas. – Jesus Shelby May 29 '15 at 21:21
  • Lol, one step ahead of you, tried that already, but no dice. Unfortunately, I think I may need to just go ahead and rebuild the server. Thanks for all the ideas! – Nick DeMayo May 30 '15 at 0:00
2

Thanks to Waqas Sawar in the comments above, who pointed me to this link:

That was nearly the answer, but, since the App Installation Service was a Farm-Scoped job, and not a Web Application scoped one, I had to do a little more digging.

I then came across this article:

which gave me the powershell needed to restore the Default Farm-Scoped jobs:

$farm = Get-SPFarm
$farm.TimerService.EnsureDefaultJobs()

After running that I was again able to deploy apps!

If you could, when upvoting this answer, please upvote Waqas' comment above as well!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.