I have several columns to input a number, the field is required with a default value of zero. This works fine when filling out the form, but once they save it then go back into the form the user can now put a blank value in that column and re-save the form and it doesn't reject it. I'm confused as to why validation only works during the first form fill and not after and how to avoid it.

I need to pull the data into an access database and I can't have blank values they cause all sorts of problems.

edit: Sorry I lied even though the fields are checked with Requires that this columns contain information it does allow a blank value even during first form fill, it hasn't always been that way. I did edit the form using InfoPath but even in InfoPath those fields are checked with "Cannot be blank".

  • can you confirm that the edit form isn't actually a custom edit form? the behavior you describe seems pretty strange.
    – SPArcheon
    Commented May 29, 2015 at 8:06

1 Answer 1


Are you using any custom form with JavaScript validation, that is only on the form while creating new entry? But not while editing it? Best way to make that column/field mandatory is , go to list settings, click on column and chose radio button YES for required field.

Just saw your edit. Now we know that you are having Infopath form. Infopath form does accept blank spaces even when we say cannot be blank

If you are expecting users to enter number, you can have simple validation rule added there. may be field < 0, then show error message that only numbers greater than 0 are expected as an input.

  • It's already a required field it does reject a blank value when the form is first filled out but after that they can go in and put a blank value in and it doesn't reject it, I don't get it. edit: I should add the only validation I have is "Require this field contains information" is checked to yes, evidently a blank value is "information".
    – zeddgara
    Commented May 29, 2015 at 8:02
  • Can you please provide sharepoint version details. I tested this on sharepoint online for custom list and it doesnt allow me to put blank value (or space ) on edit.
    – Rohit
    Commented May 29, 2015 at 8:10
  • SharePoint 2010, beats me it should not allow blanks but it does.
    – zeddgara
    Commented May 29, 2015 at 8:34
  • this is something related more to infopath than sharepoint :-)...infopath accept blank spaces hence its working. Adding validation rules wont take long
    – Rohit
    Commented May 29, 2015 at 8:40
  • I opened the form in InfoPath and just republished it to the sharepoint list and now it's working, some obscure bug probably. Anyways it's fixed!
    – zeddgara
    Commented May 29, 2015 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.