1

I followed Microsoft's article and setup Workflow for SharePoint. Double verified with this article http://sharepoint-community.net/profiles/blogs/configuring-sharepoint-2013-to-support-workflow-management.

SP designer on the App server where Workflow is installed still says Platform type 2010. "The option for the SharePoint 2013 workflow platform is not available because workflow service is not configured on the server...."

This is what I have done..

localhost:12291 - Works
SP2013App:12291 - works from both server and outside of the server
Service Application associations is checked with the web application
Central admin /_admin/WorkflowServiceStatus.aspx - Workflow is Connected
PowerShell verification - works

Get-SPWorkFlowConfig -webapplication http://sp2013-test.domain.com
EmailNoPermissionParticipantsEnabled             SendDocumentToExternalParticipants                   DeclarativeWorkflowsEnabled
       ------------------------------------             ----------------------------------                   ---------------------------
                                          True                                          False                                          True`

Ran SP config - successful
2

After reading some article, i learned I did not have App management service and subscription setup. http://nikpatel.net/2013/09/11/sharepoint-2013-workflow-manager-hidden-dependency-app-management-service-proxy. After provisioning these 2 services and iisreset on all sp server problem has gone. Now, SP designer shows Workflow 2013.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.