1

I have the following site collection:

https://mytenant.sharepoint.com/sites/site1

On this site collection on the Style Library we have a folder and a few .css inside.

http://screencast.com/t/KfIz6E0xDp4

On our masterpage we render some css files

<SharePoint:CssRegistration name="<%$SPUrl:~sitecollection/Style Library/SPCxxxx/COREV15.css%>" runat="server" after="SharepointCssFile" />
    <SharePoint:CssRegistration name="<%$SPUrl:~sitecollection/Style Library/SPCxxxx/colors.css%>" runat="server" after="SharepointCssFile" />

Then we have some subsites: https://mytenant.sharepoint.com/sites/site1/apps/ourappsubsite1

If we logon as a site collection administrator on the subsite, then we can see the colors defined in colors.CSS, and if we check View Source Code, the colors.css is rendered correctly.

However with some users, on that subsite, the line colors.css is not rendered. IT JUST DOESNT APPEAR. Not even the LINK HTML tag.

So we thought it has to be with permissions.

On site collection level we checked the style library and has unique permissions, it also has the Restricted Read Permission Level.

If we check the file and then check permissions for one of the problematic users, it says the user DOES have permission.

If we add that USER to the Designers Group, then it works, the tag is rendered on the browser and we can see it on View Source.

So, we thought, what about if we create another permission level with the same permissions as Design, then we create another Group with that permission level, and then start removing checkboxes.

We did that and added the user to that new group, and it doesnt work, not even having the same checkboxes on the permission level.

I cant add that user to design because then they would be able to create lists, and many more things.

  • 2
    Is the masterpage checked in and published? also check css files, if they need to be checked in? – Ransher Singh May 28 '15 at 17:03
4

Check in and publish as major version the masterpage

0

None of it helped me, my css is in site Assets(office 365). What did-go to 'Site Settings' > 'Master page' and at the bottom open Alternate CSS URL > choose file and (if need it for all subsites) click Reset all subsites to inherit this alternate CSS URL

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.