0

Whenever I open the ascx page for a visual web part in Visual Studio, it takes 4-5 seconds or more with a loading popup that says "Communicating with SharePoint".

Why does this happen?

Is there any way to remove the dependency with SharePoint because this makes Visual Studio very slow and laggy.

  • 1
    Can you check if this helps: Select the SharePoint project - > Press F4 -> Set Server connection property to Offline – Nadeem Yousuf May 28 '15 at 10:01
  • I think it worked. I can't be sure though. I need to test it after a while as it does that when you open the ascx file not used in sometime. But the question remain, why does it communicate with SharePoint when opening an ascx file ? And why is there a setting for Online and Offline ? – Talha Sayed May 28 '15 at 10:35
  • 1
    Consider that you have a content type deployed to site. Now you want to inherit a child content type from it. Communicating with SharePoint allows it to appear in the list of content types in the add content type wizard – Nadeem Yousuf May 28 '15 at 10:41
3

Select the SharePoint project - > Press F4 -> Set Server connection property to Offline. The SharePoint solution communicates with SharePoint when server connection is set to true and URL is specified in the properties.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.