2

I am trying to link to an excel file located on another sharepoint site in my domain. Whenever I attempt to link to the file it will not make any attempt to open in the excel web app (sharepoint will instead offer to download the file to my computer). Is there a way to force it to do this?

The file will open in the web app if I browse to it through its library, but if I link directly to it (where the url ends in .xslm) my browser will always just download the file instead. I tried copying the url of the webapp page (while this file is open), but that link eventually stopped working (I'm assuming it was because someone had updated the file).

  • 2
    Try append ?web=1 to the doc url. – Bunzab May 27 '15 at 11:43
2

Enable client integration at web application level

  1. In SharePoint Central Administration site, click Application Management->Manage Web Applications, select the web application for the site.
  2. Click Authentication Providers, select default zone, and select Yes for "Enable Client Integration?" Configure setting to open Office document in client application:
  3. In SharePoint Central Administration site, click Site Actions->Site Settings Under Site Collection Administration, click Site collection features For "Open Documents in Client Applications by Default", click Activate For "Office Web Apps”, click Deactivate

Let me know if you have any questions

  • Hello, thanks for your suggestion. The suggestion that bunzab had (?web=1) did the trick – lacrosse1991 May 27 '15 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.