1

enter image description here

Following is my log details

Microsoft.Office.Server.Administration.SetupLicensingException: There is no known SharePoint Server Product installed. at Microsoft.Office.Server.Administration.SetupLicensing.get_InstalledOfficeServersProduct() at Microsoft.Office.Server.Administration.SearchHelper.get_IsSearchSKU() at Microsoft.SharePoint.Portal.WebControls.SearchBoxEx.OnPreRender(Object sender, EventArgs e) at System.Web.UI.Control.OnPreRender(EventArgs e) at Microsoft.SharePoint.WebPartPages.WebPart.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveIn... 126249db-3bcb-4bf0-a195-a7d32f79e44e 06/11/2011 15:59:46.25* w3wp.exe (0x0280) 0x1070 SharePoint Foundation Runtime tkau Unexpected ...ternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 126249db-3bcb-4bf0-a195-a7d32f79e44e 06/11/2011 15:59:46.25 w3wp.exe (0x0280)

Please help me to over come this problem. My server I just reinstalled my MS office and it Licensed version.

2 Answers 2

0

Has this solution been migrated from Windows SharePoint Services or other MOSS 2007 SKU? It looks like the exception hints that there is some sort of SKU/License issue

3
  • Last time when i used Every thing was working fine what i did just format my D: Drive in because my system running out of space in C: drive. (Drive D I installed office 2007) My C drive I installed office 2010 Trial version. So i did remove some register keys of office 2007. It may be the issue Jun 12, 2011 at 7:10
  • I deleted all my site collection and recreate all site. I am facing the same error. Now What I did i try to open the site in SharePoint Designer I able to open the Site in SharePoint Designer. 1. home/_layouts/settings.aspx but when i try to open the this(home/_layouts/viewlsts.aspx) link i am geeting the same error logs -------------------------------------Microsoft.Office.Server.Administration.SetupLicensingException: There is no known SharePoint Server Product installed. at Microsoft.Office.Server.Administration.SetupLicensing.get_InstalledOfficeServersProduct() Jun 12, 2011 at 8:16
  • That sounds like a plausible source. You probably deleted the wrong regkeys.if you did not take a backup of your regkeys, ou should look start looking for backups of the servers OS... Hope it wasnt a production environment... Jun 12, 2011 at 9:14
0

Some Troubleshooting worth trying:

  1. Try checking options under "Upgrade and Migration" under central administration
  2. "Enable Features on existing sites " Try this option under "Upgrade and Migration" in Central Administration
  3. Run configuration wizard.
2
  • I ran Configuration wizard too. but i wont help me. When ever i try to create a new site collection. I got the same error. that I show you above. Jun 12, 2011 at 7:13
  • please let me know if this work for me. the exact error message I am getting glorix.blogspot.com/2007/09/… Jun 12, 2011 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.