I have a form that uses dropdowns with associated lists. When selected, the items in the associated list run off the side of the page. ![List items disappear][1] When the drop down is selected, the bottom scroll bar shows up, but if you navigate to move the scroll bar to the right, you lose your drop down, and subsequently lose your scroll bar. Is there a simple way to resolve this so that all items in the drop down can be visible? Thanks!

EDIT: Here's the Systems Access List: ![Systems Access][2] In SP Designer, Edit Columns: ![Columns][3]

(images removed)

  • Are you pulling in the values from a table? Are you wanting to have less text showing in the drop down or just to widen the drop down?
    – Graham
    May 26, 2015 at 20:30
  • Hi Graham, Thanks for your comment. It's pulling in from a column in a table where the Systems Access (from the picture above) is associated with a Job Title. Systems Access is one column in the table. Ideally this drop down should populate based on the job title entered previously in the form, but it doesn't. (welcome to SharePoint right?) So, I guess at this point, unless I can figure out a way to get it to autopopulate, I just need to be able to move the drop down to the left so that all items are seen, or give it some sort of wrapping function. Thanks for your help!
    – Anonymous
    May 27, 2015 at 13:04
  • The picture above looks like it's pulling in a row of data, not a specific column in a row. Can you edit your question with the code that you've got calling that? I think you need to specify which column you want specifically.
    – Graham
    May 27, 2015 at 13:17
  • Okay, I've made some edits with some images. Please let me know if you need more info. Thanks again for your help!
    – Anonymous
    May 27, 2015 at 16:44
  • What specifically is calling that code for the drop-down, though? Is that a web part, javascript, Infopath or HTML?
    – Graham
    May 27, 2015 at 18:37

1 Answer 1


After 20 items SharePoint changes the behavior of lookup drop down for better performance and this many time cause usability issues for end users...you can try revert back to normal drop down by editing form and adding a InDesign property to Form Field as shown below

<SharePoint:FormField  InDesign="true" 

Other then this... you always have option to change css and reference it from your master page, so that css changes are applied on complete site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.