0

I've got a weird bug in one of the SharePoint 2013 Foundation farms. Search Service is configured. Full crawl went OK with no errors. Now, when I'm trying to click on one of the links below. I get an eror:

enter image description here

enter image description here

Stack trace:

WebException: The remote server returned an error: (403) Forbidden.] Microsoft.Office.Server.Search.Internal.UI.SearchObjectAdminPageBase.ErrorHandler(Object sender, EventArgs e) +296 System.Web.UI.Page.HandleError(Exception e) +164 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +12573451 System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +12572973 System.Web.UI.Page.ProcessRequest() +119 System.Web.UI.Page.ProcessRequest(HttpContext context) +99 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

Additinal info:

  • Search Server pool and Application app pools are site collection administrators if matters.
  • I don't get any access denied errors anywhere else on the portal, including Search Center Service Application.
  • I can access any page on the portal with no restrictions whatsoever.

I will be grateful for any suggestions as to why this is happening.

0

Here is the 2007 solution, think it should work for 2013 as well: http://blogs.technet.com/b/sushrao/archive/2009/03/26/microsoft-office-sharepoint-server-2007-moss-403-forbidden-error-when-clicked-on-search-settings-page.aspx

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • This worked for me in 2010 and since these mechanics haven't changed it should still work in 2013. – Quatic May 26 '15 at 12:09
  • thank you, but WSS_WPG group already had all permissions to the Tasks folder. App Pool and Search accounts are members for this group – Denis Molodtsov May 26 '15 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.