0

I have added an AppOnlySequence to my workflow and inside it there is a HttpSend activity which perform a GET operation on a host web list item. But I don't get any response back.

Once I remove the AppOnlySequence the HttpSend works just fine.

I've also configured my environment according to following post.

https://msdn.microsoft.com/en-us/library/office/jj822159.aspx

0

I found the solution. You have to enable "Allow the app to make app-only calls to Sharepoint" in AppManifest.xml under permissions.

Then the XML would look like this.

<AppPermissionRequests AllowAppOnlyPolicy="true">
    <AppPermissionRequest Scope="http://sharepoint/content/sitecollection/web" Right="FullControl" />
</AppPermissionRequests>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.