0

No search service is available error on SharePoint 2010

We've a SharePoint 2010 site running on SharePoint 2013 server. The site works fine in 2013 except for the search service.

I get an error when I tried to enter a keyword and search

"Your search cannot be completed because of no search service is available. Contact your administrator for more information"

I've checked the following
Crawling & search service application - Up & running
Index component is active
Search topology - all OK
SharePoint server enterprise search and site search (Manage web application features) = Active
Search crawling account has full access to the web application
Did a cache.ini reset and tried to run the

psconfig.exe -cmd services -install 

and

stsadm -o spsearch -action start 

I get an error

" A search service instance could not be found on server in the farm"

Is there any way to get the search working?

  • 1
    If you open CA -> Service on Farm -> Can you see the service running? How many servers you have in your farm? – Amal Hashim May 20 '15 at 22:02
  • @AmalHashim we've 3 application servers and 2 web servers. SharePoint Server search service is up & running on all the servers – drag May 20 '15 at 22:28
  • 1
    Is the proxy added to the default proxy group for the web application? – Jesus Shelby May 20 '15 at 22:59
  • @JesusShelby In the "Configure Service Application Associations" screen everything is ticked. Search service application, secure store service application and state service prody etc. – drag May 20 '15 at 23:13
  • 1
    Do you have other sites in the same web app that work with Search? If no -then attempt to create a new search service and swap them out in the proxy group to test. Also - does your topology match where you are running services? You may have services listening but no endpoints actually living on those machines if you don't. Maybe isolate by removing all instances except for a single machine, than capture live ULS and Network traffic when accessing the services, and possibly even Process Monitor to be sure you are not getting access denied to files or registry entries on the host machine. – Jesus Shelby May 21 '15 at 1:43
0

Sorry @drag - but it is looking like you may have an issue with the site collection itself. I would backup and restore the site collection to a new location (new URL) in the same web application but with a new Database.

If that works - consider removing your current site and re-add from the same backup procedure into a new database. If you hit errors in the process it may mean that the problem lies in the config database and not the content databases.

In either case if the issue persists I would consider opening a Microsoft Ticket.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.