1

I'm an admin on our SharePoint 2010 install, however I don't seem to have permissions to delete pages or content. I've tried logging in with my own account as well as the global administrator account, but neither have the access I need. Both are listed in the farm administrators list, but yet the options I need to use are grayed out (apparently due to permissions somewhere). It's been a very long time since I've worked on this site, but I don't remember this being a problem before.

Is there some other permissions that I need in order to make content changes? If so, where are those set up?

So far I've been hunting around in Central Administration as well as googling, but keep coming up empty. Seems like I may need some extra "Design" permission that I've somehow lost, but I can't seem to locate where/how that's setup.

  • 1
    Farm administrator has full permission. You can open site settings -> permission and make yourself site owner and see if that helps. – Amal Hashim May 20 '15 at 15:26
  • 1
    Check if you are site collection admin. – Dolgsthrasir May 20 '15 at 15:29
  • Well, gee, I'm in the site owner list, but oddly it throws errors about "no permission" when I try to view the various permission subgroups. Looking into the site collection admin thing now. – Brian Knoblauch May 20 '15 at 15:37
  • I've now also given myself "Full Control" for "all sites" in the "User Policy" tab. No change. – Brian Knoblauch May 20 '15 at 18:53
1

To get the access inside the Site collection you need be as Site collection admin or Full control. You get this done by this.

This will give the access to one site collection:

  • From central admin > application management > change site collection admin
  • On this page from drop down select the web app > site collection which admin you want to change, then add your id either Primary or secondary Admin field.

Another Method, which will give you access all web apps in the Web application.

  • From Central admin > Application management > manage web application
  • On this page click on the web app and from Ribbon click on User Policy
  • Now add your id as full control.
  • Now you will access everything under that web application.

Farm admin group doesnot give you access all site collections in the farm.

|improve this answer|||||
  • Helpful, but did not solve the issue. The 2 site collection admins were people that don't even work for us anymore, replace them with myself and our sysadmin. I have publish tabs now, but still no delete permission. I then tried the second method, but am unable to do it as the User Policy option is grayed out. I must be missing something that depends on somewhere. – Brian Knoblauch May 20 '15 at 16:40
  • can you share the Screen Shot, also Check the Permission policy if delete option i removed from the all permissions...any restriction on the library which prevent to delete....try to cfreate another test library and test it....also try from diferent browser – Waqas Sarwar MVP May 20 '15 at 16:44
  • Well, when I do a Permissions check on my name for a particular page it returns "Delete item allowed", but yet the delete button is still grayed out. :-O – Brian Knoblauch May 20 '15 at 18:56
  • did you try with different library or browser – Waqas Sarwar MVP May 20 '15 at 18:59
  • Same with IE, Firefox, and Chrome. – Brian Knoblauch May 20 '15 at 19:20
0

It magically started working on its own one day... I'd tried SharePoint Designer as well as finding I had some hidden subsites that I needed to delete (and did). Not sure if any of that is related, but all of a sudden I was able to do what I needed throughout the site.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.