Users cannot see the Managed Navigation menu. One person can see it but the others not. I have added them as site collection administrators, but still can't see it. What could be the reason?

Farm Administrator is the owner of the Term Set. That's how we have set it on testing environment as well and there it is working just fine.

I have entered the AppPool service account in the MM Service permissions group, but still no luck.

Update 1: I thought it could be that the master page and javascript was not published so, I published it but still not luck again.


I solved it eventually. I had to delete the TermSets in MMS and recreate them again, but this time manually. It seems that there was a problem when the termSets were created via powershell script. So, a few things to keep in mind:

1) the owner of the term set must be "farm administrator" account
2) if menu do not show up, then recreate them manually rather then via powershell
3) Master page, javascript, etc must be published

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.