1

How can I edit the forms for a new Document set?

I've added a column of the type hyperlink to the content type Document set, and I'm filling this column with a workflow after the creation/editing of document sets. I don't want users to see this column when filling in the form, but the column can't be set to hidden (for several reasons).

If there's the alternative of changing properties of the form field so that users can't fill it in, then that is fine.

This is regarding SharePoint Online (Office 365) and I have full access with the SharePoint Designer software.

(sidequestion: from what i've seen, I can't set a default for this type of column without the use of powershell. Is this correct? Is there no possible alternative by perhaps editing the form?)

1

I would use InfoPath to remove the field from your form, but as that is deprecated, I don't know how Microsoft wants us to do that in the future.

To answer your side-question, best way I've modified many fields at once is via workflow to do the edit and use a dummy field which I change value on.

Open the list in datasheet view, make a change in the top field then left click and drag down with your mouse (very similar to working in excel). If your workflow is set to update on item change, the workflow will fire and change your field value. When done either delete the dummy field or just hide it from my form using InfoPath.

Other people may have better options, but I've always been limited to OOTB, no code.

EDIT: can you drop the field in the form into a section and hide the section based off of a rule (which will never become successful so it always hides? Something like id=0)

  • How do I get infoPath to work for me in this case though? I've been able to get InfoPath to show me forms in some cases, but I don't know how to do it for this case. – dammkewl May 20 '15 at 6:53
  • The problem is I don't know how to open a form for this in InfoPath. – dammkewl May 20 '15 at 13:57
  • AH ok. you can either go to the ribbon, Click List> Customize Form, that should open InfoPath designer (if you have it, it is part of the office pro install), or it should prompt you to get it. – DLoweinc May 20 '15 at 15:40
  • AH ok. you can either go to the ribbon, Click List> Customize Form, that should open InfoPath designer (if you have it, it is part of the office pro install), or it should prompt you to get it. I believe the plan on office 365 that gets it is the E3 plan. I am an admin on my o365 so I can go to the admin dashboard, search for "Software download" and InfoPath gets listed as one of the apps. Once InfoPath is installed you should be able to open it, select Design Form and put in the URL to your site, it may ask you to select your list, or create a new one. I cant add pics right now, hope it helps – DLoweinc May 20 '15 at 16:02
  • I can't seem to find where to be in the designer, so that the "Customize Form" action pops up in my ribbon. – dammkewl May 26 '15 at 12:00
2

A way would be to use SharePoint designer to change the New/Edit/View forms to a application page. Provided you know enough to edit the markup.

The following steps would suffice.

  1. Create a Application Page
  2. Open the List With SharePoint Designer
  3. Under the hedding Forms Click New.

    3.1 Create whichever type of form you would like to change.

    3.2 Edit it to your liking.

    3.3 Set it as default.

1
  1. Go to Advanced Settings and Enable the Allow management of content types.

  2. Now you will see the content types associated with the list under the Settings section.

  3. Click on Item or the specific Content type.

  4. Select the column.

  5. Check the Hidden radio button.

You can also do this by adding a js file to your page and adding the following lines of code:

ExecuteOrDelayUntilScriptLoaded(init,'sp.js');
function init(){
    $('nobr:contains("Field name")').closest('tr').hide();

}
  • As I've stated in my question, the column can't be set to hidden for multiple reasons. The 2 main reasons are that reusable workflows can't set values in hidden fields (and the alternative of column association doesn't work for my case), and hidden columns can't be shown to users in the document library. – dammkewl May 20 '15 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.