1

I am connecting to REST Web Service through InfoPath 2010 and when I publish the form i am getting below error :

A query to retrieve form data cannot be completed because this action would violate cross-domain restrictions.

If this form template is published to a SharePoint document library, cross-domain access for user form templates must be enabled under InfoPath Forms Services in SharePoint Central Administration, and the data connection settings must be stored in a UDC file in a data connection library in the same site collection.

If this is an administrator-approved form template, the security level of the form must be set to full trust, or the data connection settings must be stored in a UDC file by using the Manage data connection files option under InfoPath Forms Services in SharePoint Central Administration.

An entry has been added to the Windows event log of the server.

Log ID:6932
Correlation ID:607521b0-cef5-452f-9814-6edb7ca1bfb3"

I have these settings in Central Administration Alloww cross domian access and Allow user form templates to use authentication information contained in data connection files checked. And also I have udcx file in site.

Can any one suggest solution for this.

enter image description here

0

If you have load balanced Web front ends you can try these suggestions:

  • Under InfoPath Form Options > Security and Trust ensure the "Automatically determine security level" in unticked
  • You mentioned the URL points to 2 different servers, if they are load balanced, ensure that there is a host entry on each server pointing to itself, this is because the request could bounce between servers and loose context

https://social.msdn.microsoft.com/Forums/en-US/eeaafd97-75cd-4875-bb2b-faa6647c61e0/infopath-forms-cross-domain-issue?forum=sharepointcustomizationprevious (from MSDN)

  • DLowenic I am not having any issue when I do this in my local domain. It is occuring only in product5ion and more over I dont find the option "Automatically determine security level" in my InfoPath options. Please find the image above the options I am having in Advanced options of form. Do i need to go somewhere to set that option you mentioned or is my form missing some thing else to get that option. Thanks. – SPLearner May 19 '15 at 10:56
  • I think the "automatically determine security level" is only for form library forms, not list forms so you may not see that option. For a Form library form you can see it by opening up that form>Select Form Options>Security and trust. If you still get an error only in production (because I assume you are testing by using "Preview" which works in the InfoPath filler client, this is probably a "double hop issue" where each web front end needs an entry in the host file pointing to itself. – DLoweinc May 19 '15 at 16:29
  • Hi Dlowenic when I mentioned it is working in my local machine it is with regards to the form published in my local domain when i try to publish the form in production i get the error. Now i could see a different error "Unable to connect to the remote server An entry has been added to the Windows event log of the server. Log ID:5566 Correlation ID:6aa20f6d-dafc-4df8-bf45-48c099cccdbf" – SPLearner May 19 '15 at 19:31
  • is it possible that since you are publishing from Dev to Prod that the GUID is bad? If you remove the data connection and re-add it on production, does that have any impact? I've ran into similar issues with using a "dev" / "prod" environment (different site collections) and GUID's really became a problem for me. – DLoweinc May 19 '15 at 19:39
  • I have tried it multiple times on re adding but of no use :-( .. I am thinking that it is not authorizing the web service. I have seen some where on Google to mention authentication in udc file do you have any idea how to do it? – SPLearner May 19 '15 at 19:43
0

Cross domain issues occur if we are trying to use the the web service which don't have access with the domain where we are trying to implement the InfoPath. Make sure if the user has permission to the service and domain he is accessing to. Host the web service in the current server and it accesses through the service. But need to remember these steps while making data connection in InfoPath to REST Web Service I have updated the steps in the following link please follow them in case of reference to others who face these issues.

Steps to follow adding REST web Service as data connection in InfoPath

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.