1

I want to backup/restore the Search service application from a test farm to a production farm. I performed the classic backup of the service application from Powershell:

Backup-SPFarm -Directory C:\Temp -BackupMethod Full -Item "Farm\Shared Services\Shared Services Applications\Search Service" 

I have then tried to run both Restore-SPFarm and restore through Central administration but I get the following error while restoring both CrawlStore and LinksStore database:

An error occurred while processing the log for database 'SharePointSearchDB_LinksStore'. If possible, restore from backup. If a backup is not available, it might be necessary to rebuild the log.

EDIT -> Important additional info: the restore of the databases on the source farm gives NO errors. The backup are not damaged, the problem is the restoring of LinksStore and CrawlStore on a new farm.

The log looks like:

[5/18/2015 3:39:30 PM] Progress: [SharePointSearchDB_LinksStore] 100 percent complete. [5/18/2015 3:39:35 PM] Verbose: [SharePointSearchDB_LinksStore] SQL Server Message: Processed 3544 pages for database 'SharePointSearchDB_LinksStore', file 'SharePointSearchDB_LinksStore' on file 1. [5/18/2015 3:39:35 PM] Verbose: [SharePointSearchDB_LinksStore] SQL Server Message: Processed 11208 pages for database 'SharePointSearchDB_LinksStore', file 'SharePointSearchDB_LinksStore_log' on file 1. [5/18/2015 3:39:55 PM] Warning: [SharePointSearchDB_LinksStore] An error occurred while processing the log for database 'SharePointSearchDB_LinksStore'. If possible, restore from backup. If a backup is not available, it might be necessary to rebuild the log. RESTORE DATABASE is terminating abnormally. [5/18/2015 3:39:55 PM] Debug: [SharePointSearchDB_LinksStore] at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData() at System.Data.SqlClient.SqlDataReader.get_MetaData() at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource1 completion, Int32 timeout, Task& task, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) at Microsoft.SharePoint.Administration.Backup.SPSqlBackupRestoreHelper.RunCommand(SqlCommand sqlCommand, SPBackupRestoreInformation args, Boolean throwOnRestart, Boolean& restart, SPSqlBackupRestoreConnection connection) [5/18/2015 3:39:55 PM] Warning: [SharePointSearchDB_LinksStore] SQL command failed and needs to be restarted. The command will be re-started a total of three times before throwing an exception.

Admin and AnalyticsReportingStore are restored correctly.

Manual backup and restore on LinksStore and CrawlStore dbs can be performed smoothly on SQL Server and I'm not using any particular backup configuration. What can cause the problem?

  • try with a fresh backup...looks like log file corrutped – Waqas Sarwar MVP May 18 '15 at 18:17
  • Do you have a SQL Server database backup? I'd try those instead if available. (Good Question +1) – Benny Skogberg May 18 '15 at 20:21
  • I have an older backup but is not updated as I would need... and I've already tried to re-perform the backup but I'm still getting the same error. But as I was saying, if I perform the backup from SQL and not from SharePoint (Backup-SPFarm), the error doesn't appear! – Mafalda89 May 18 '15 at 21:09
  • Important additional info: trying to restore the potentially damaged backup on the source farm I get NO error. The problem is then in the restoring of LinksStore and CrawlStore on a new farm. But this is a standard procedure from Technet! – Mafalda89 May 19 '15 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.