12

When installing prerequisite for SharePoint 2013

it fails and give error:

Error: The tool was unable to install Application Server Role, Web Server (IIS) Role

can anyone tell me why it fails

I searched the Net MS link: https://support.microsoft.com/en-us/kb/2765260 but it also did not work or maybe I could not understand it

can anyone tell me how to fix it.

3

13 Answers 13

12

Are you trying to install on Windows Server 2016? This is not supported officialy, but easily possible:

*Preprare Windows and SQL Server, Setup AD DS

*As already stated, install .NET 3.5 with server manager

*add Features manually using Powershell:

Add-WindowsFeature NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-Pipe-Activation45,NET-WCF-HTTP-Activation45,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Asp-Net45,Web-Net-Ext,Web-Net-Ext45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Xps-Viewer -verbose

*Run prereq installer

*Reboot

*Install Sharepoint

Fun!

Cheers!

3
  • That's exactly what I'm trying to do, install 2013 on 2016 Server. The prereq installer keeps mentioning something about Application-Server, which doesn't seem to be a feature option on 2016. I've added all the features through powershell on support.microsoft.com/en-us/help/2765260/… (minus the AS prefixed ones) and also what you've typed. No luck. Re-running the prereq fails Jul 21 '17 at 0:09
  • 5
    Oh, figured it out. You also need to copy the file C:\windows\System32\ServerManager.exe and rename the file to: ServerManagerCMD.exe (ref: social.technet.microsoft.com/Forums/office/en-US/… ) Jul 21 '17 at 0:13
  • this also work when trying to install SharePoint 2016 on Windows Server 2016 Standard (GUI) without any update. Just need to specified the source file D:\source\sxs
    – Ariwibawa
    Sep 12 '18 at 4:22
8

My problem was solved by installing of .Net 3.5 feature in my server

by going to server manager add/remove features

than I re run the prerequisite installer again and it worked

hope this will help other peoples facing same issue

6

Follow this Post. It works fine by renaming the ServerManager.exe to ServerManagerCMD.exe

http://www.someshinyobject.com/posts/server-2012-r2-and-sharepoint-2013-the-tool-was-unable-to-install-application-server-role-web

2
  • 1
    It should be noted that you shouldn't just rename ServerManager.exe. You should copy it first and then rename the copied file. Jul 21 '16 at 1:12
  • Cant find serverManager.exe in my windows 10 pro OS. Please help Mar 4 '19 at 6:30
3

tried to run prereqs for SP 2013 and 2016, both gave the same hickup.

In both ways the solution given above : It works fine by renaming the ServerManager.exe to ServerManagerCMD.exe

But I solved this differently. I just copied Servermanager.exe in system32, pasted the copy back and named that one ServerManagerCMD.exe

This is again the proof that Microsoft cannot be reached to present them with solutions from the field so that they will correct that scripting mistake in prequisites.exe for future releases, because in the current sharepoint 2016 official iso it is still there. What a waste of our time!

2
  • It's ridiculous but this fixed my prereq installer as well, using a stock Azure image no less! It's not comforting that what essentially boils down to a typo hasn't been fixed yet.
    – Jane Panda
    Mar 13 '16 at 16:58
  • It drove me nuts that the prereq-installer just throw error after error. This little hint just solved the issue.
    – airliner
    Jul 14 '20 at 5:27
3

You will need to install the .Net 3.5 framework feature using the server manager tool. However, in some scenarios like in WS2012 R2... installation of the .net 3.5 framework will give an error.

In order to fix this, you will need to "specify an alternate source path". Insert a WS2012 installation media in the computer ( it can be a USB or a ISO )

alternative path

Then search in the installation media for the folder "\sources\sxs\" and set that as source for the feature installation and click install. Installation will success if you use this procedure.

Source article here - in Spansih

1

couple of things:

  1. try to run this command C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regii -enable -i
  2. try to add the IIS manually from Server Manager > Roles
  3. check this http://social.technet.microsoft.com/wiki/contents/articles/23268.sharepoint-2013-the-tool-was-unable-to-install-application-server-role-web-server-iis-role.aspx
1

In my case this was caused by McAfee Antivirus being installed on the server. I removed McAfee completely and then the prerequisite installer ran without problems.

1

I had this issue using the Windows Azure VM. As mentioned above it was caused by not having .NET 3.5 installed.

I did the following:

  1. Downloaded the Windows Server 2016 ISO and mounted it on F:\
  2. In server manager added the 3.5 role
  3. Specified the file location as F:\sources\sxs

The SharePoint pre-req then worked fine.

1

Tryed all solutions above, and nothing worked. The link below ended up working for me.

https://sharelockpoint.wordpress.com/2013/09/09/sharepoint-2013-pre-requisites-install-fail-error-the-tool-was-unable-to-install-application-server-role-web-server-iis-role/

1
  • 1
    Welcome to the SharePoint S.E.! Thanks for adding to the responses... But could you please revise your answer to explain what exactly you did? Links often break, and if they do your answer will no longer be helpful for those who need it. Many people will just copy/paste parts of the web page, then still have the link to the original page at the bottom of the post. Thank you!
    – KGlasier
    Apr 17 '19 at 14:44
0

My answer will trump (pun intended) all of yours as far as ridiculousness goes. After trying every one of the resolutions in this post and a 1.5 day search..nothing worked for my environment.

What finally worked was starting and setting the IIS Admin Service to automatic then running the Prerequisite installer-laughable, I know. :)

Thanks for all the advice-I hope mine helps someone in need.

0

go to command run: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis -enable -i Fix my problem

make sure the path and file name match your computer path

0

A general solution might be that you run manually the same script that the installer does.

  1. Try to run prerequisiteinstaller.exe and see it fail.
  2. Before closing the tool's window click on "Review the log file".
  3. In Notepad, by initializing a Save as command, copy the file's name to the clipboard. Search your system's drives for it. For example, you might find it in %userprofile%\AppData\Local\Temp\.
  4. Start an elevated PowerShell window (run as admin), and switch to the above folder.
  5. In this folder you'll se at least one .ps1 file with a modification time about the same as the installer tool's execution. Probably it will be named like Pre---.tmp.PS1. (You'll find a .log file too, with the same name, containing the reason while it did fail. You can try figuring it out, or you can just skip to the next step.)
  6. Run this .ps1 file in the PowerShell window.

After this, the prerequisiteinstaller.exe will skip IIS modules and step to the next item.

-2

Method 1 Install the hotfix that is described in Microsoft Knowledge Base (KB) article 2771431. For more information about hotfix 2771431, click the following article number to view the article in the Microsoft Knowledge Base:

2771431 A servicing stack update is available for Windows 8 and Windows Server 2012

Note Although KB 2771431 states that you do not have to restart your computer in order to apply the hotfix, you must restart the SharePoint Server as part of the installation process after you apply this hotfix. Method 2 Use this method only if you cannot install hotfix 2771431 as described in the "Method 1" section.

Make sure that the server meets the minimum hardware requirements for SharePoint Server 2013. For more information about the minimum hardware requirements for SharePoint Server 2013, go to the following Microsoft TechNet website
Hardware and software requirements for SharePoint 2013
Manually install the Windows Server 2012 Roles and Features that are required by SharePoint 2013. To do this, use one of the following methods, depending on whether the SharePoint server is connected to the Internet or is offline.

Content Source: https://support.microsoft.com/en-us/help/2765260/the-products-preparation-tool-in-sharepoint-server-2013-may-not-progre

Not the answer you're looking for? Browse other questions tagged or ask your own question.