3

Our client attached a database from SP 2013 testing environment to SP 2013 Production env. Now they are getting the error: http 400 bad request.

I have never done this before, so I was wondering if there are any tips as to what might be causing this, or where can I start to look for the issue?

I have checked the IIS, the sites and the pools are running fine. I have restarted them by the way. And I have checked the ULS logs and I see nothing there related to http 400 bad request.

Any ideas?

  • 1
    How many site collections in the Content DB? try this...detach the content db from web app and then re-add it using the powershell – Waqas Sarwar MVP May 18 '15 at 12:46
  • at the moment not so many, around 15. I just tried to dismount it, but I got Dismount-SPContentDatabase : The DELETE permission was denied on the object 'SiteCounts', database 'SharePoint_Config', schema 'dbo'. I asked the client to do it since I don't have the right permissions. – Imir Hoxha May 18 '15 at 13:07
  • 1
    do you have access to central admin, you can detach it from their and re attach it – Waqas Sarwar MVP May 18 '15 at 13:25
  • Thanks man. That worked. I did it via CA. I was focused on powershell and I forgot CA :) – Imir Hoxha May 18 '15 at 13:41
  • fix the problem? – Waqas Sarwar MVP May 18 '15 at 13:48
1

Some time when you attach a Content DB to the web application, it could not get updated all places in SharePoint. In this kind of sitution, we follow the below steps to fix it.

  1. Dettach the Content DB from Web App, using Central admin or Powershell
  2. Re attach the Content DB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.