0

Right - before this gets marked as a duplicate, I have tried numerous suggestions for my issue, none of which have been successful.

Here is what I need to do:

  • Hide Site Settings link from sprocket at top of page for Non-Admins
  • Hide Settings link from Site Contents page for Non-Admins

Of the suggestions I have come across, I have tried updating the Master page - that resulted in all of my pages displaying a "You do not have permission to view this page" error.

Why these links are available to standard visitors in the first place is beyond me. These are Admin features, with no easy way of hiding them for general site visitors.

Why does it have to be so difficult to modify simple settings such as this?

Any direction would be most welcome.

  • "Why does it have to be so difficult"? Because this is SharePoint! Frustration is an integral part of the experience ;) – MdMazzotti May 17 '15 at 9:00
2

I feel you, I had the same problem, therefore I only can tell you about my experience and you need to see whether it matches your problem.

What I need to mention at the beginning is, that the visibility of those settings come with the "Permission Level" of a group.

I have implemented a Document Library on a site, where users can post document sets and documents (in the document sets). Of course, they should be allowed to freely edit, delete and add items into that library. However, they must not change value from lists or edit properties.

What I've done was to set the permission for this certain usergroup generally to "READ" (Site Settings > Site Permissions > Check Group > Permission Levels), but in the document library itself to "Contribute" (Site Contents > your Document Library > Library Settings > Permissions for this... > Stop Inheriting..> Check Group > Permission Levels).

With this way, the certain group won't see the setting-icon on the main view, but in document sets. They can access the site contents (lists etc.), but not edit them in any way.

I hope this helps you at least a little.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.