2

I am trying to activate "Site Feed" feature in my Site Collection, but I am getting the following errors via UI:

UI:

SiteFeedFeatureReceiver: can only be enabled on the same farm where MySites are deployed. 

My Sites is created and running correctly. In one of the blogs was stated that this error is caused because of the limited permissions for the current user in "User profile synchronization"

I have added my user account in the permissions, but it still doesn't work.

1

I found the solution.

It seems that there were two User Profile Services. So what I did was this: go to CA>Application Management > Configure Service application associations and made the first UPS as default one and deselected the other one, which did not do anything and was not correct.

I hope this one helps someone.

enter image description here

enter image description here

  • 1
    Just out of curiosity, why would you need 2 user profiles services? – Christoffer May 13 '15 at 11:35
  • No, it is not needed but I am not the one who set up the SharePoint Server and done the configuration. As you can see, even the name is not correct and not professional. They have use the GUID in the name. My task is to install and configure the solutions. – Imir Hoxha May 13 '15 at 11:56
0

I had the same issue, and I checked my code MANY times...

My code needed to switch the feature on in all webs, and the code was :

$webs = Get-SPSite -Identity "https://SITECOLLECTION" | Get-SPWeb -Limit all
$newsFeed = Get-SPFeature | Where{$_.Id -eq "15a572c6-e545-4d32-897a-bab6f5846e18"}    
foreach ($web in $webs) {
Enable-SPFeature -Url $site.Url -Identity $NewsFeed
}
$site.Dispose() 

It turned out that the feature activation script needed to be ran as the farm account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.