0

I want to edit the column property of "location" in my list, to make it required when submit the form. But when I click list setting, select "location" column,this is all I got:

"location" column setting page: "location" column setting page


List setting page: List setting page


Advanced setting page: Advanced setting page

So, how do I make this column required when submit the form?

2 Answers 2

1
  1. Go to Advanced Settings and Enable the Allow management of content types.

  2. Now you will see the content types associated with the list under the Settings section.

  3. Click on Item.

  4. Select the column.

  5. Check the Required radio button.

6
  • Thanks for the help. But "allow management of content types" is already enabled.
    – SSilicon
    Commented May 12, 2015 at 17:34
  • Do you see Item under content types?
    – Keerthi
    Commented May 12, 2015 at 17:39
  • Really sorry but I'm not sure what you mean here, I've added more screen shot to show my current set up. Even "Allow management of content types" is enabled I still only see two lines in my column setting page.
    – SSilicon
    Commented May 12, 2015 at 17:58
  • Click on Event under content types.
    – Keerthi
    Commented May 12, 2015 at 17:59
  • Oh nevermind, I changed it in event page by clicking the "location" . Thank you!
    – SSilicon
    Commented May 12, 2015 at 18:14
1

You may have to do this in Powershell.

$site = Get-SPSite -Identity "http://sharepoint/" #change
$web= $site.OpenWeb()   
$spList = $web.GetList("/Lists/CustomList") #change 
$field = $spList.Fields["Location"]
$field.Required=$true
$field.Update()
$web.Dispose()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.