3

We are trying to embed Excel using SharePoint Excel Services and we are getting the following error,

We're sorry. We ran into problem completing your request. Please try again in few minutes Error

We have tried all the trouble shooting tips provided in the following link and tried restarting the server also,

http://sharepoint-community.net/profiles/blogs/excel-services-application-issues-sp-2010-2013

Below is the screenshot of the error shown while debugged using JIT debugger (Note: ASP .NET Impersonation is disabled for the site),

Failed to load engine.dll. Access denied

Exception

Stack Trace:

StackTrace

Please help us to resolve this issue.

1
  • look at Application pool.if any stop ,start it.it may be about Excel service pool.
    – Hossein
    Commented Aug 8, 2015 at 5:49

2 Answers 2

2

The issue was that the web site used for the SharePoint Web Services had the ASP.NET Impersonation Authentication method enabled.

The solution is to disable the ASP.NET Impersonation again.

Go to IIS Manager (Start, Administrative Tools, Internet Information Services (IIS) Manager). Expand the Sites node on the server running the Excel Services Service Application. Choose the Authentication icon in the IIS area. Choose ASP.NET Impersonation in the list and disable it using the action link on the right hand side.

Source

2

It is working after disabling Impersonation

1.) Start IIS -> Expand Server -> Expand Sites

2.) Select SharePoint Web Services Site and click on Authentication from right panel.

3.) Disable ASP.NET Impersonation (if enabled)

1
  • Yes that's exactly what I suggested in my answer :)
    – Submits
    Commented May 12, 2015 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.