0

I made an approval workflow in SP Designer 2013 for my custom list on a 2013 site.

My workflow waits for the column "submit for approval?" to equal yes then it sends an email to the approver. Then it waits for the column "Approved?" to equal yes then it is supposed to send an email to the creator saying that it has been approved. For some reason the second email never sends and the workflow becomes suspended.

I get this long error message,

RequestorId: 06262505-fdc3-c27e-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ArgumentNullException: Value cannot be null. Parameter name: Input at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Any ideas on why this is happening?

  • Can you share a screen shot of your workflow please? Images are always better when explaining :) – Muhammedh May 12 '15 at 6:38
0

I was never able to get this to work with 1 workflow but I did find a work around by making a second workflow. I placed the second half of my workflow (the half that was failing) and put it on a second workflow by itself and everything works the way it is supposed to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.