0

We are using SP2013 enterprise on-premise. On a site collection we have setup a content search webpart to show latest updated documents and pages.

Supposingly the webpart should show the title of pages and document (office word, excel, powerpoint). However, I found it is showing the first sentence of document instead.

After some investigation, I tested when I key in the "title" field when upload the document, CSWP will show this "title" properly.

However, for the old documents, whatever I do to update, the CSWP still show the 1st sentence. (I have tried key in the title field, delete the doc and upload again, update the content of document, etc) All the documents I tested (old or new) are resident in the same library.

What is the problem?

  • 1
    Did you run full crawl after changing the Title for the old documents? – Arsalan Adam Khatri May 11 '15 at 5:51
  • No. I have not tried index reset or full crawl because I want to find a less-annoying way to make the Title show up on CSWP. Do you think it is the only way? – Mark L May 11 '15 at 6:01
  • Content Search Web Part fetches data using Search configuration. So If you updated any properties in item, You need to do the crawling so that that change will be reflected on the search result. It is necessary. – Pradip R. May 11 '15 at 6:15
  • I have scheduled incremental crawl every 15 min. In fact, for "new document" that correctly show the "title, any update to the "title" reflect on CSWP after 15 min. The problem is "old document" never get their "title" correctly show. – Mark L May 11 '15 at 6:17
  • Tested "full crawl without index reset" do not help update the title. – Mark L May 11 '15 at 9:52
0

There is a bug for SharePoint 2013 on crawled property priority. The managed property "Title" is mapped to crawled property "MetadataExtractorTitle" by default at first priority and there was no way to change the order of this crawled property unless October 2013 Cumulative Update was released on October 26th, 2013. After the patch applied, you can now configure the priority (in my case, the "MetadataExtractorTitle" is at toppest and cause the problem)

Here is the steps to configure the priority (after you patched CU Oct 2013):

  1. Central Administration > Search Service Application > Search Schema and search for managed property "Title".

  2. At the mappings of the managed property, move the mapped crawled property "MetadataExtractorTitle" down to the last position and save the managed property.

  3. Reset index and process full crawl.

Reference: Fixed: Search Results not showing Document Titles

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.