I have a Web application(http://extranet:80 - Default Zone) running only on claims authentication and with a Trusted Identity provider and no NTLM, obviously content from this site wasn’t being crawled , so we created an extension (http://extranetsearch:81 - Custom Zone) whit NTLM to make it work, the crawl log shows that there’s content being successfully crawled from the extended site but when I do a search on any of this sites there’s no results, I´ve been checking the logs and apparently there’s no error in the crawl component nor the query processor, I ‘ve been testing the search using different user accounts, site admin and the search service account and still no results.

So I’m clueless about what could cause this kind of behavior any help will be highly appreciated.


2 Answers 2


I ran into something similar recently. Lots of crawled content, but empty search results. In my case, switching the search application to store as Claims solved the problem.

$SearchApp = Get-SPServiceApplication SearchAppName

$SearchApp.setproperty(“ForceClaimACLs”, 1)

I still don't know what the exact underlying issue was, but I believe it is related to the search service or crawl account not being able to read certain attributes on AD accounts.

  • Same here. Goes for One-way domain trusts too
    – Colin
    Jun 9, 2011 at 8:50

Does it work if you search from the custom zone? My guess is that the search security trimming rejects all results when you are searching from the default zone that does not use a NTLM authentication provider. You will probably need to enable anonymous access and do a full crawl to see any results.

  • Thanks for answering!! but.. Nope, still no results even when doing a search from the custom zone, I´m going to enable anonymous on both sites and see if that works.. Jun 8, 2011 at 17:24
  • It might also help to swap the zones. Search prefers to authenticate against the default zone. Jun 8, 2011 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.