2

My users have the default 'Read' permissions set on SharePoint online, but the option to sync a document library is not available for them. What is the minimum required permission level to be able to sync a document library?

1

According to this blog: http://nickheylen.com/2014/05/15/sync-error-we-cant-connect-to-the-specified-sharepoint-site/

You must either give the following persmission:

  • Use remote interfaces
  • Use Client Integrations features
  • Open

or

If you disable the ‘Limited-access user permission lockdown mode’ feature via ‘Manage Site Collection Features’ at the site collection level, the problem is also solved.

2
  • Thanks for the quick response. The permissions were set correctly, but I am testing the second step.
    – bmartin
    May 7 '15 at 14:29
  • ok, hope it works out
    – Pantani
    May 8 '15 at 8:01
0

Make sure synchronisation is enabled at the site level:

  1. Go to site settings.
  2. Go to search -> search and offline availability
  3. Select YES for option: availability offlineclient

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.