8

On our Intranet I have activated the site collection feature "Open Documents in Client Applications by Default". On the Document libraries I have also set the *Default open behavior for browser-enabled documents* to *Open in the client application*.

When opening excel-files directly from the document library the files open in correctly in Excel. When we search for the excel document, it tries to open in the browser and we get an error. It is the same behavior for IE, Firefox and Chrome.

I found a workaround by modifying the serverfilesExcelServer.xml in 15 hivelike this:

<ServerFiles>
    <!--<Mapping FileExtension="xlsx" RedirectUrlTemplate="/_layouts/15/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" /> -->
    <Mapping FileExtension="xlsb" RedirectUrlTemplate="/_layouts/15/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" />
    <Mapping FileExtension="xlsm" RedirectUrlTemplate="/_layouts/15/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" />
    <Mapping FileExtension="ods" RedirectUrlTemplate="/_layouts/15/xlviewer.aspx?id=|0" NoGetRedirect="TRUE" />
</ServerFiles>

But I don't think it is a good way to solve this problem, and probably unsupported. Any ideas on how I can fix this problem ? Is there any supported way to fix this ? Will our environment be unsupported if I implement this fix with commenting out the line in the servilesExcelServer.xml

Thanks

4

Is this behavior for all users or only few and what about browser? In the real world scenario it should work,

  • just make sure the Enable Client Integration at web app level.

    Central Administration > Application Management > Manage Web Applications > select the web application > Click Authentication Providers > select default zone, and select Yes for "Enable Client Integration?"

  • Also enable the "Open Documents in Client Applications by Default" on central admin site collection.

But if it did not work that's mean your environment required special treatment,which is commenting the code line in the XML files, which you already did. This workaround is fully supported as Microsoft rep post a blog on technet.

Configure SharePoint Server to Open Office Documents in Client Application by Default

  • Hi Waqas. Thanks for the input, very valuable. It's the same for all users I have tested with, and on all browsers I have tested on (IE, Firefox and Chrome). Also, we don't use office web apps. – Ilyas May 7 '15 at 12:55
  • 1
    then your option is what you already did....believe me this happen all time and vary from farm to farm. – Waqas Sarwar MVP May 7 '15 at 13:00
  • I beilive you :), but very strange behavior in SharePoint. – Ilyas May 7 '15 at 13:46
1

If you have the excel Service enabled then this problem is most probably with ASP.NET Impersonation.

Solution:

Disable the ASP.NET Impersonation at the Server level and "SharePoint Web Services" level. Via: IIS > Authentication > ASP.NET Impersonation

-- Microsoft Knowledgebase entry

IF no ECS configured in the farm then check this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.