11

I have a SharePoint list. There I have created a new column "Department". I want to keep it hidden when adding new item and edit item. It should be visible in list view. No code base (OOTB).

  • 1
    I did that, but it is not working. Is it because I am using InfoPath? I tried saving the form in InfoPath with the changes imported from the site, and republishing, but it basically undoes the "hide". Any ideas? – gajames Jun 16 '17 at 17:45
  • Yes. It's applicable for SharePoint OOTB form only. – Sivakumar Piratheeban Jun 19 '17 at 8:41
15
  • To begin, go to List Settings > Advanced Settings
  • Select Yes on Allow management of content types
  • Click on one of the existing content types under the Content Type section Next, click on the column you intend to hide, and choose the option Hidden. Click OK
  • Go to the New Item tab and select the Edit form. You will see that, on both the New Item and Edit forms, the field that you want to hide is not shown, and you're able to save the item without filling in a value for it.
  • 1
    Content Types section is normally hidden and it will be visible after "Select Yes on Allow management of content types" step. – Furkan Ekinci Mar 9 '17 at 7:28
  • @FurkanEkinci You can reset the option to no when you are finished making your changes and that should re-hide it. – TylerH Jan 15 '18 at 15:59

protected by Community Jun 16 '17 at 17:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.