2

I attempted to restore a farm backed up from server A to server B (SP 2010).

When I run the restore, I get the error: "Requested registry access is not allowed".

Not sure which key I need to change permissions on, or what user to grant.

But I gave the network account farmadmin (which is what the timer service runs with) full permission on the Sharepoint 14 registry folder.

Still get the same error - any help appreciated.

thanks.

0

are you using the network service account for the restore? why not use the regular with local admin rights on the server and permission on DB server.

if you want to set the permission on registry then follow this:

  1. Open the registry by run regedit on the server where the SP2010 is installed.
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\OFFICE SERVER\14.0 Right click and choose Permission..
  3. Add WSS_ADMIN_WPG and give Full permission to this Group.
  4. Add WSS_WPG and give Read permission to this Group.
  5. Restart the server.

http://blogs.technet.com/b/spsforum/archive/2011/11/02/quick-solution-5-requested-registry-access-is-not-allowed.aspx

If you still having the issue then use the Process Monitor and find the key where access denied is thrown.

  • I could only find the WSS_ADMIN group and gave full permissions to this account on that key. How can I confirm which account I am using for the restore? – Perplexed May 6 '15 at 15:01
  • it is the account under which you login on the server. – Waqas Sarwar MVP May 6 '15 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.