1

I have added a few content types in a Content Type Hub site collection. I am am unable to see this content types in another site collection. Is there any setting that I should enable so that the content types created in content type hub can be used in other site collections?

  • Have you published them in the hub? And made sure the content typ hub subscriber timer job has ran? – Robert Lindgren May 6 '15 at 11:22
  • I am using Sharepoint Online. I have published the content type. I have been looking for a serviceJobDefinitions page but unable to find it. Do you have any idea where it is located? @RobertLindgren – Gokul N K May 6 '15 at 11:36
  • In SharePoint Online you do not have access to the timer jobs (since it is a shared environment). So you just need to have som patience for the job to run. In on-prem I think it is run once every hour, but it may not be the same in the cloud – Robert Lindgren May 6 '15 at 11:37
  • @RobertLindgren thanks for the clarification. Can you share this as an answer so that I can accept your answer. – Gokul N K May 6 '15 at 11:40
1

Two things to make sure:

  1. Make sure you have published the content types in the hub (as described here)
  2. Run the timer job called "Content Type Hub Subscriber" for the web application that the site you want the content type on belongs to from Central Adminstration.

    Note: This is not possible in Office 365 (SharePoint Online), since you can not manually run timer jobs in this environment. Instead, here patients is the key (wait for it to run).

  • waiting patiently for the timer jobs to run :P – Gokul N K May 6 '15 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.