2

We have 3 web applications in our SharePoint 2013-intranet solution. Two of them works fine. On the third one "sometimes" users get Access denied. This includes farm admin users as well.

After following this tip, the problem is solved (enabling Anonymous auth, waiting, verifying and set it back). But a few hours/days the problem occurs again and its keeps happening.

Anyone have got this or have a clue were to look/compare with the other, working web applications?

8
  • what authentication being used? also how manys ite collections in that web app? what template is being used for root site collection? – Waqas Sarwar MVP May 5 '15 at 14:13
  • Hej Waqas! Thanks for a Quick response :) we are using Claims Based Auth(on all) and ordinary http (not https). Right now there are only one site coll on the webapp. The root site is using BLANKINTERNET on the non-working, BLANKINTERNET on one of the working (root)sites and STS on the other working – Cowborg May 5 '15 at 14:30
  • did ou configure the Object Cache(Super User and Super Reader) on that web app? – Waqas Sarwar MVP May 5 '15 at 14:31
  • No, for none of the web apps – Cowborg May 5 '15 at 14:36
  • try to configure that and then test it....make sure when you run the powershell dont froget the adding claims with your super user and reader account claim:domain\spreader...technet.microsoft.com/en-us/library/ff758656.aspx – Waqas Sarwar MVP May 5 '15 at 14:37
0

This is very much common error now days which occur when you ignore the Object Cache Settings. So Please Configure the Object Cache settings for that web App.

  • Create the Super User and Super Reader Account
  • Add Both account into Policy for web app, Super Reader as Full read and Super User as Full control
  • Now run the below power shell to add the user:

    $wa = Get-SPWebApplication -Identity ""

    $wa.Properties["portalsuperuseraccount"] = ""

    $wa.Properties["portalsuperreaderaccount"] = ""

    $wa.Update()

  • IIS reset on all server in the farm.

Note: when you add the user in the powershell,Dont Forget the Claims in start of account i.e.claim:domain\spreader.

Configure object cache user accounts in SharePoint Server 2013

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.