4

I migrate a site collection from version 2010 to the 2013.
I have a list with a custom content type. (document set).
When I try to open a document with the url

mysite/listName/Forms/myContentType/docsethomepage.aspx?ID=1

I get the error

File Not Found

I checked the log and the error is on this file

mysite/_controltemplates/ToolBar.ascx

The file ToolBar.ascx exists in the hive /15/ControlTemplates/

I tried to remove the import of that page from the docsethomepage.aspx page of the content type (_cts/myContentType/docsethomepage.aspx) but it is still not working.

UPDATE

I tread to delete the page _cts/myContentType/docsethomepage.aspx but I still get the same error, so I guess I am editing the wrong page.

  • Can you see the document inside the library? – Amal Hashim May 5 '15 at 12:43
  • yes, I can open the document library and I can see the property of the item (with the custom content type). But when I try to open an item (click on the document set) I get the error – Nk SP May 5 '15 at 12:44
  • You can open up SPD and check if the Page got migrated or not. – Amal Hashim May 5 '15 at 12:52
  • The page is there, but my, but if I change the page _cts/myContentType/docsethomepage.aspx I do not see changes – Nk SP May 5 '15 at 12:53
1

I've come across this issue in the past. In the end I had to carry out these steps:

  1. Delete the docsethomepage.aspx file.
  2. Copy in a fresh docsethomepage.aspx file.
  3. Check out the docsethomepage.aspx file, then check it back in.
  4. Go into the document set's settings and check Update the Welcome Page of Document Sets inheriting from this content type

This was where I found my answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.