4

I have multi server farm environment and I have configured my search service in server where my SharePoint server web applications are running,

my server architecture: enter image description here

How can I run the search service in another server? The server I want to move search service to name is MAX01

When I run the below command:

$hostA = Get-SPEnterpriseSearchServiceInstance -Identity "MAX01"

it gives this error:

The SearchServiceInstance is not found on server "MAX01"

  • Pls reconfirm the server name. The server name should be "MAX01", not "MAX01.com". Remove the ".com" postfix and try again. – Zakir HC May 3 '15 at 6:39
  • Yes I miss spelled it here, I wrote the name correctly when running command, but the above error I mentioned – Mehdi Jalal May 3 '15 at 6:43
  • After modifying the servername, is it working now? If not then close your management shell and reopen the run the command again. – Zakir HC May 3 '15 at 6:50
  • Yes the same error – Mehdi Jalal May 3 '15 at 8:06
3

To move the Search Components of SharePoint 2013 to another server can be done via PowerShell. There is no way to move the Search via Central Administration or modifying the Search Topology.

It would be too long to post entire set of steps and commands here in the answer. Therefore I refer you two articles that would help you to move the Search to another server.

Move a Search Component in SharePoint 2013

Move Search Components To Different Server in SharePoint 2013

Before you move your search to another server, ensure you have planned your Search Architecture as per the best recommendation. Search is a service in SharePoint that needs most of the system resources or else your search components would not run upto the mark.

Plan enterprise search architecture in SharePoint Server 2013

  • Take content db of search service application in your source server using SSMS or PowerShell and restore these DBs on your target server. – userAZLogicApps May 4 '15 at 12:08
  • These links did not work, do you have another detailed solution – Mehdi Jalal May 5 '15 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.