0

I was trying to test Offline Installation of SharePoint on my Virtual Machine. I installed SharePoint 2013 using Powershell, Installed WorkFlow Manager Refresh and Service Bus 1.1 using Web Platform installer. I have installed and configured Workflow Manager client 1.0. Everything works like a charm. However when I open a site inside SPD and try to create a List or Site Workflow, SharePoint 2013 workflow missing in the dropdownlist.

1

It seems the site collection was created using blank template, which doesn't include all necessary dependency features for creating workflows.

To fix this you need to enable hidden feature WorkflowServiceStore using PowerShell.

Enable-SPFeature -Identity WorkflowServiceStore –Url $yourUrl

for more detail: http://anujabhojani.blogspot.in/2013/06/the-option-for-sharepoint-2013-workflow.html

  • Thanks Anuja, the site collection created based on Team Site template and when I run the powershell to activate the feature it says the feature is already activated on the scope... – Medes May 1 '15 at 9:19
1

At least from the description of your steps it seems you might have missed the registration step:

Confirm that Workflow is configured correctly by navigating to:

https://URLOFWORKFLOWAP:12290/
http://URLOFWORKFLOWAP:12291/ 

for http.

If you receive the scope info xml you are probably ok.

Then using account that is part of the WF Admin group and is SP farm admin run this command:

Register-SPWorkflowService -SPSite "<URLofTheSharepointWebApp>" -WorkflowHostUri "https://URLOFWORKFLOWAP:12290/" -ScopeName "<EnterNameOfScope use this example "DevMachiene2">" -AllowOAuthHttp -force

After that command you should see a new workflow proxy service application in Central Admin, click on it and confirm that it shows Connected.

If shows connected you are almost done... now wait 15 minutes or run this command so the topology service can see it as well: Start-SPTimerJob job-spconnectedserviceapplication-addressesrefresh

If you have registered the Workflow Manager then check this: I have seen that on some occasions the Workflow Application Proxy doesn't get associated with the application even though you run register command in that case you sill won't be able to author workflows. This is easy to check go to Central Admin (CA_URL/_admin/ApplicationAssociations.aspx) and ensure SharePoint Web App is has association with the workflow service.

0

Unless, it's resolved already, here's a simpler way, especially for those who are not farm admins Site Settings > WorkFlow Settings > WorkFlow Health > Enable Workflow Store Service

Ref: http://sadomovalex.blogspot.in/2015/06/enable-sharepoint-2013-workflows-in.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.