1

I'm quite new to sharepoint programming and so I ran into a problem.

I created a new webpart in my solution and changed it a bit. Next I deployed the whole solution and added the webpart to a newly created site. The webpart showed everything I implemented in there so I thought it works.

The problem is, that when I make changes on the webpart and deploy it again, the webpart on the site won't change. Even if i add the webpart again, the changes won't be there.

What do I need to do to see the changes on my webpart?

Thanks in advance! Katex

2

I'm also relatively new to SharePoint development, but will try share some of my experience. :)

When I created new code/functionality to a site, I make sure that I 'deactivate' the webpart/feature, then under your Admin Settings I retract the solution from the farm.

Before I package the solution in Visual Studio, I update both the .feature title and description (with whatever changes I made, so at least I can tell changes are getting deployed in the text description) and then I update the Assembly Information of the solution (increment it by 1). Then 'publish'.

Once published and deployed, I then, for good measure, reset the IIS and then finally activate the feature on the site.

This might not be the exact same process you are going through, but doing the above has been a sure fire way that changes to my deployment get reflected each time. :)

  • Pretty much. IISReset is the default thing to do because some processes might not have been properly updated during the deployment. – user2536 Apr 30 '15 at 11:13
  • I found that often doing an IISReset still wouldnt show solution changes and actually changin the assembly info in my project before publishing helped. But if just resetting the IIS works most of the time, then the better! – Simon Apr 30 '15 at 12:06
0

We had the same issue in recent past, where our team updating a wsp but for some reason it was not updating it properly. We tried.

  • remove the solution completely and redeploy it.
  • reset IIS.

ON/Off it is working n not. But one thing we noticed if we reboot the server then it updated. Finally with the help of MS, we figured out what's happening.

  • even we update the wsp but for some reason Timer Job still had old DLL which is causing the issue.

MSFT recommend us to restart the Both SharePoint Admin and SharePoint Timer Jobs from Services Console.

0

We also faced this issue. To resolve this, after deployment we went to site collection feature, deactivated that feature and again activated the feature. This solved the issue for us.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.