0

I want to enable search in my SharePoint 2013

when I click on crawl rule it give blow error:

 System.InvalidOperationException: The search service is not able to connect  to the machine that hosts the administration component. Verify that the  administration component '84caf2fc-6524-4f55-b090-07db8450fb0f' in search  application 'SPSearch Service Application' is in a good state and try again. 
  at   Microsoft.Office.Server.Search.Administration.SearchApi..ctor(SearchServiceApplication application) 
  at Microsoft.Office.Server.Search.Administration.SearchServiceApplication.get_SearchApi() 
  at Microsoft.Office.Server.Search.Administration.CrawlRuleCollection.InitCache() 
  at Microsoft.Office.Server.Search.Administration.CrawlRuleCollection..ctor(Content parent) 
  at Microsoft.Office.Server.Search.Administration.Content.get_CrawlRules() 
  at Microsoft.Office.Server.Search.Internal.UI.WebControls.ManageCrawlRulesControl.OnLoad(EventArgs e) 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Control.LoadRecursive() 
  at System.Web.UI.Page.ProcessRequestMain(Boolean  includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 
3
  • 1
    Have you scaled out your search service application to another server or did you split up the components to different servers? If you go the the search service, are any of the components marked with a red icon or are they all green? Apr 29, 2015 at 6:41
  • And how old are your search service? How did you create it? Which script did you use? Has it worked fine until now? Are it still returning results as expected? Apr 29, 2015 at 6:45
  • Hello , please go to the ULS logs and check if the error below is getting displayed for Sharepoint Search . Let me know if you are able to see this and i will tell you the fix. Error in log :- "Could not access the Search database. A generic error occurred while trying to access the database to obtain the schema version info." Aug 5, 2019 at 7:26

1 Answer 1

0

There could be several reasons for this issue.

  1. Check in IIS, if the application pool hosting the Search Service Application has sufficient access.
  2. The search admin timer job might be disabled or stopped. Execute below to check:

    Get-SPTimerJob job-application-server-admin-service | fl
    

It may return IsDisabled : True. If this happens then execute below:

Enable-SPTimerJob job-application-server-admin-service

Now it will return IsDisables: False. Now restart SharePoint Timer Service from Service.msc

  1. Check the service account which is running Search Service Application has full access to it. Check it through Central Admin > Security > Configure Service Accounts.

You can verify your above steps here in this ARTICLE.

  1. Follow the steps as given in this ARTICLE if none of above solves the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.