2

A multiline text field on my OOTB display form in my SP 2013 list will appear as:

#1

#2

#3

On a custom form (before I make any changes to it), it will appear as:

#1 #2 #3 with the "\n" still being in place instead of being converted to "
" as it does on the OOTB form.

I tried adding disable output-escaping = "yes", but this didn't seem to change anything. What am I missing?

1

To resolve this issue, I used the follwoing XSL expression. It was working as expected.

<xsl:value-of disable-output-escaping=”yes”   select=”ddwrt:AutoNewLine(string(@History))” ddwrt:nbsp-preserve = “yes”/>

Here:

  • History is my Multiline Text column in SharePoint list with Plain Text format
  • ddwrt:AutoNewLine is to apply Line Breaks
  • ddwrt:nbsp-preserve is to Disable Special Characters

Apply Line Breaks & Disable Special Characters on Multiline Plain Text Column of SharePoint List Custom Display Form

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.