I have created a workflow which cannot be started by any other user who are receiving this error

A form template (.xsn) file cannot be accessed. You may not have the required permissions to open the file

On further search I found out that the workflow's .xsn file is checked out to me as shown in the image enter image description here

Is there a way to check-in or publish the file?


I had this before, you should just be able to open the site the workflow sits on in SP designer, go to all files, find the workflow in the folder structure (think it is under workflows -> forms off the top of my head) then you get the option to check it back in. If it errors and says -

cannot perform this operation, the file is no longer checked out or has been deleted

Then follow this http://passionatetechie.blogspot.sg/2012/03/spd-workflow-error-solved-cannot.html

Hope this helps!


I have fixed this issue. When I tried to implement Jamie's suggestion, I got an error saying that not all the properties are filled. So I went into the content types via designer and made the "Title" from required to optional. I then went ahead and opened the InfoPath file and removed the existing InfoPath file from the workflow and published my existing workflow.

I then published the InfoPath form and followed Jamie's suggestion.

Hope it helps and thank you all for your wonderful suggestions :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.