1

I am working with a SharePoint 2013 app and I need to debug it against a developer site. However, I am getting the following error in Visual Studio using F5 to debug:

Error occurred in deployment step 'Install app for SharePoint': The remote server returned an unexpected response: (405) Method Not Allowed.

I have tried this with multiple developer sites, but they all return the same error.

Anyone know a good place to start with this kind of error? I'm new to SP2013 development but am familiar with SP2010.

  • What sort of app is it? What does it contain? – wjervis Apr 27 '15 at 18:01
0

In 2013 sharepoint development, you are supposed to pass the correct url of the sharepoint site to which the app or solution is going to be deployed. if the site url you have mentioned is not accessible from the development server in which the visual studio is present then you will get the same error after pressing F5 because it failed to find the server url to deploy the app.

for development or deploying sharepoint apps you should be able to atleast access the site from the same environment which responds via port 80 or some other port thats being used.

i would also recommend to revisit the permissions on the target site. Also there is a concept of sideloading of apps when you dont use developer template in 2013 version which can cause these kind of issues.

0

I had received similar error while deploying my app to a different O365 site in different domain. This occurs due to different/mismatch Client Id and client Secret in Web.Config and AppManifest.xml. Make sure these values match in both of these files and the app is registered on your Developer site collection.

Hope this helps !! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.