1

Server A was connected to farm A. I uninstalled SharePoint and installed again to create farm B in the same SQL Server.

The SharePoint installation is successfull, however when I try to run the configuration wizard to create the config database (from gui or console) I get the following error and stack trace:

An exception of type System.ComponentModel.Win32Exception was thrown.        Additonal excption information: 
 The data area passed to a system call is too small.
 at   Microsoft.SharePoint.Administration.
 SPServer.GrantRevokeReadAccessToSCManagerAndCryptSvc

In the ULS log, the error that I'm seeing is this:

Ensuring WSS_WPG read access to cryptsvc service.
Failed to open cryptsvc service: 122

After a bit of reserve engineering, I got the excat system call that is failing:

Advapi32.OpenService(sPServiceSafeHandle, "CRYPTSVC", 393216u)

I tried the following to solve my issue:

  • Ensuring setup account rights (SQL sysadmin, machine administrators group, etc.)
  • Reinstalling SharePoint (again)
  • Changing setup account to my own domain account
  • Deleted WSS_WPG local groups
  • Restarting machine, restarting cryptographic service
  • Enabling randomly windows disabled services
  • Uninstalling SharePoint updates and tried RTM release

Not working, what now do except try to wipe and recreate VM?

  • did you perform complete uninstall the sharepoint from server?also make sure following permission for wss-wpg technet.microsoft.com/en-us/library/cc678863.aspx#Section5 – Waqas Sarwar MVP Apr 24 '15 at 19:40
  • make sure WSS-WPG having permission on wind\system32 folder. – Waqas Sarwar MVP Apr 24 '15 at 19:43
  • @WaqasSarwarMCSE Yes I did a complete uninstall/reinstall from the server. It says on the technet link that the configuration should grant those permissions to WSS-WPG. I must grant them manually to the folders before the configuration is ran? – Machinegon Apr 24 '15 at 20:39
0

This was resolved by removing all GPOs on this particular machine and rebooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.